phpのバージョンをアップデートしたら「Warning: Use of undefined constant」って出る

先日wordpressで運営されているサイトのサーバーを変更したところ

「Warning: Use of undefined constant   – assumed ‘ ’ (this will throw an Error in a future version of PHP) ×××.php on line 1234」

って感じでエラーが出るようになりました。
どうやら、サムネイルの呼び出しのphpがエラーになっているみたい。。

問題となっている箇所は

だったのですが、
「.$eye_img[0].」の前後に半角スペースを入れ

としたところ、解決しました。
なんでだろう。。

シングルクォーテーションとダブルクォーテーションの部分の記述が厳格になっているようです。
その後、もう一度

に戻しても問題なく動きます。。
謎です。

ちなみにGMOサーバーです。。
とにかく、原因不明ですが解消はしました。。
同現象でお困りの方がおりましたら、お試しください。。

それでは。

役に立った 6

役に立ったボタン設置してみました。是非押していってくださいm(__)m(2020年4月17日設置)

この記事を書いた人

mako110

原宿でWEBディレクターをやっています。
WEB業界に携わって約15年。独立して7年目です。
自分らしく、働きやすく、周りの人の役に立つ。
そんな仕事をゆるゆるとやっています。